Trending ▼   ResFinder  

ICSE − Q & A

ICSE
Indian Certificate of Secondary Education (ICSE), New Delhi
+Fave Message

Ask a Question

Answer a Question!

ResFinder - Thousands of Practice Papers

WAP to input a word and remove the consecutive repeated characters by replacing the sequence of repeated characters by its single occurance
Sample Input:Jaaaaaavvvvvvvvaaaaaaaaa
Sample Output:Java

Would this program be accepted?
import java.util.*;
public class Q8
{
    static void main()
    {
        Scanner ob=new Scanner(System.in);
        System.out.println("Input String:");
        String s=ob.nextLine();
        s=s+"*";
        int i;int j;
        for(i=0;i<s.length()-1;i++)
        {
            char ch=s.charAt(i);
            if(ch==s.charAt(i+1))
            continue;
            else
            System.out.print(s.charAt(i));
        }
    }
}
asked by Siddhant Joshi (siddhant94) 6 years ago
3
Write the output for the following:
String s="Today is Test" ;
System.out.println(s.indexOf('T'));
System.out.println(s.substring(0,7) + " " +"Holiday");


According to me, the answer should be:Today is Holiday.
But the marking scheme says that it is:Today i Holiday [OR] Today Holiday 

Pls explain which is correct, and WHY TF are two answers being accepted?
asked by Gargie D'souza (gar_d02) 6 years ago
5
Can someone give me the order of logical, relational, and arithmetic operators?
asked by Pavan K Srinivasan (throwaway) 6 years ago
1
Is function call by reference there in the syllabus? will the icse instruct to write the programmes using only call by reference method?
asked by Sameed Hussain (sameed) 6 years ago
1
how many of you have completed and how many just started comp theory?
asked by Ashutosh Dash (ashutosh_dash) 6 years ago
3

+ 1 more questions by ashutosh_dash  

Why is a class known as composite data type?
asked by Niraj Gupta (solution86) 6 years ago
3
Guys 1%5=0 right???
asked by Tiara Elizabeth (thejtthomas) 6 years ago
3
__This program is for finding automorphic number ....but it is not working on bluej.....plz tell what's incorrect??__


import java.util.*;

public class Main
{
	public static void main(String[] args)
	{
		
		Scanner input = new Scanner(System.in);
		System.out.println("enter number");
		
int n=input.nextInt();
int r;int s=0;
int sq=n*n;
int t=sq;
int c=1;int o=0;
while(t!=0)
{
	r=t%10;
	o++;
	t=t/10;
}

int counter=0;




for(r=sq%10;sq!=0;sq=sq/10)
{
counter++;
	s=s+r*c;
	c=c*10;
	if(s==n)
	{ System.out.println("auto");
	break;
	}
	else if(counter==o)
		System.out.println("not");
	
}
		} 
}
asked by Fire Bird (firebird) 6 years ago
2
Write a program to accept numbers in a single dimensional array of size ‘N’. Create another string array of size ‘N-1’ to accept valid mathematical symbols like (+, -, /, %, *…). Calculate and display the result by performing the operations by using the symbols stored in the string array on the values stored in the integer array.

Example: 
 
int Arr[]={1,2,3,4}
String Sym[]={“+”,”/”,"*”} 
The result is 4. ((1+2)/3)*4 

HELP!!
asked by Shreya Bhagat (hermione02) 6 years ago
1
Provide me with some very hard program for a good mental workout and practice.
Please ,
I am providing u with one and u too please provide me some:



Take a 10 elements integer array.
Accept numbers in it from the user which can be negative or positive in the cells.
Now shift the positive numbers on the left side and the negative numbers on the right side in the same sequence as they are been provided in the array by the user.]
Now print the modified array.
Sample Input:{1,-1,2,-2,3,-3,4,-4,5,-5}
Sample Output:{1,2,3,4,5,-1,-2,-3,-4,-5}
(Note that the output can not have the sequence of the positive or negative numbers altered like the output cannot be {2,3,1,5,4,-1,-5,-3,-2,-4})
To make things a bit tough(the way my teacher made it) only 1 array can be used in the entire program.
No problem as it will never come at least in ICSE boards.
Share your tough program problems too please
asked by Rishi dey chowdhury (rishidc) 6 years ago
4

<< Prev

    Page 136    

Next Page >>

ICSE chat

© 2010 - 2024 ResPaper. Terms of ServiceContact Us Advertise with us